SYSplus Documentos electronicos PLEMSI: Winsock - Host not found - 404 can't resolve hostname to IP address

SYSplus Documentos electronicos PLEMSI: Winsock - Host not found - 404 can't resolve hostname to IP address

Error: Request failed: Error: Winsock - Host not found - 404 404 can't resolve hostname to IP address"

Diagnóstico:

Este error indica que el equipo o servidor donde se está ejecutando SYSplus no logra resolver el nombre del servidor:

api.plemsi.com

a una dirección IP válida.

En otras palabras, el sistema no puede establecer comunicación con el proveedor tecnológico PLEMSI debido a un problema de conectividad o resolución DNS.

¿Qué significa este error?

Este mensaje indica que:

  • ❌No se logra conectar con PLEMSI.
  • ❌No se alcanza a enviar el Documento Soporte o la Factura Electrónica.
  • ❌No corresponde a un error en la estructura del documento electrónico.
  • ❌No corresponde a un rechazo de la DIAN.
  • ❌No es un problema de autenticación o token.

Se trata de un inconveniente de red o resolución DNS previo al consumo de la API de PLEMSI.

 

⚠️
Posibles causas

1. Falla temporal de conexión a Internet

Validar que el servidor o equipo donde se ejecuta SYSplus tenga acceso a Internet.

Pruebas sugeridas:

ping google.com

o

nslookup google.com

Si estas pruebas fallan, el problema está relacionado con la conexión a Internet.

2. Configuración incorrecta de DNS

Ejecutar:

nslookup api.plemsi.com

Si la respuesta es:

Non-existent domain

o

Server failed

significa que el servidor DNS no está resolviendo correctamente el dominio.

3. Restricciones de Firewall o Proxy

Algunas configuraciones de seguridad pueden bloquear:

  • Dominios externos.
  • Conexiones HTTPS.
  • Servicios API.

4. Antivirus o seguridad perimetral

Se han identificado casos donde herramientas de seguridad como:

  • Sophos
  • Fortinet
  • Kaspersky
  • ESET

bloquean temporalmente conexiones HTTPS hacia servicios externos.

Se recomienda validar con el área de infraestructura o seguridad.

5. Incidente temporal del proveedor tecnológico

Aunque es menos frecuente, puede existir una indisponibilidad temporal del servicio DNS o de conectividad de PLEMSI.

Para descartar esta situación, realizar pruebas desde otro equipo o red.

Pruebas recomendadas

Desde el servidor o equipo donde está instalado SYSplus, ejecutar:

nslookup api.plemsi.com
ping api.plemsi.com
tracert api.plemsi.com

Resultado esperado

El comando:

nslookup api.plemsi.com

debe retornar una dirección IP.

Si no devuelve ninguna IP, el problema está identificado como una falla de resolución DNS.

Solución

Una vez identificada la causa, se recomienda:

  1. Validar la conectividad general a Internet.
  2. Revisar la configuración DNS del servidor.
  3. Confirmar que no existan restricciones de firewall o proxy.
  4. Verificar bloqueos por antivirus o dispositivos de seguridad.
  5. Reintentar el envío una vez restablecida la conectividad.